Discussion:
[j-nsp] Juniper-MX-960-Using the same Ge-Port as L2 and L3 !
vaibhava varma
2011-09-23 11:30:08 UTC
Permalink
Dear All

Is there is a possibility in Juniper MX-960 to configure the same
Physical Port to support L2 Bridging ie Trunk Link and also configure
same time for L3 Routing ie Sub-interfaces.

It would look something like this as listed below

{master}[edit]
root at Junos# set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
root at JUnos# set interfaces ae1 unit 0 family ethernet-switching vlan
members [ 71-73 573 ]
root at JUnos#set interfaces ae1 unit 79 vlan-id 79 family inet address 1.1.1.1/30
--
Regards
Varma
Eric Van Tol
2011-09-23 12:28:19 UTC
Permalink
-----Original Message-----
From: juniper-nsp-bounces at puck.nether.net [mailto:juniper-nsp-
bounces at puck.nether.net] On Behalf Of vaibhava varma
Sent: Friday, September 23, 2011 7:30 AM
To: juniper-nsp at puck.nether.net
Subject: [j-nsp] Juniper-MX-960-Using the same Ge-Port as L2 and L3 !
Dear All
Is there is a possibility in Juniper MX-960 to configure the same
Physical Port to support L2 Bridging ie Trunk Link and also configure
same time for L3 Routing ie Sub-interfaces.
It would look something like this as listed below
{master}[edit]
root at Junos# set interfaces ae1 unit 0 family ethernet-switching port-
mode trunk
root at JUnos# set interfaces ae1 unit 0 family ethernet-switching vlan
members [ 71-73 573 ]
root at JUnos#set interfaces ae1 unit 79 vlan-id 79 family inet address 1.1.1.1/30
Not sure about AE interfaces, but you can do this with physical interfaces:

ge-0/0/5 {
flexible-vlan-tagging;
encapsulation flexible-ethernet-services;
unit 0 {
encapsulation vlan-bridge;
family bridge {
interface-mode trunk;
vlan-id-list [ 130 131 ];
}
}
unit 32 {
vlan-id 32;
family inet {
address 192.168.54.2/30;
}
}
unit 210 {
vlan-id 210;
family inet {
address 192.168.54.177/30;
}
}
}
Bill Blackford
2011-09-23 13:28:07 UTC
Permalink
ae is the same:

ae0 {
description "Single Handoff";
vlan-tagging;
encapsulation flexible-ethernet-services;
unit 400 {
encapsulation vlan-bridge;
vlan-id 400;
}
unit 500 {
description SD-500;
vlan-id 500;
family inet {
filter {
input 100M-LIMIT;
output 100M-LIMIT;
}
address xx.xx.xx.41/30;
}
}
unit 501 {
description SD-501;
vlan-id 501;
family inet {
filter {
input 200M-LIMIT;
output 200M-LIMIT;
}
address xx.xx.xx.45/30;
}
}
}
-----Original Message-----
From: juniper-nsp-bounces at puck.nether.net [mailto:juniper-nsp-
bounces at puck.nether.net] On Behalf Of vaibhava varma
Sent: Friday, September 23, 2011 7:30 AM
To: juniper-nsp at puck.nether.net
Subject: [j-nsp] Juniper-MX-960-Using the same Ge-Port as L2 and L3 !
Dear All
Is there is a possibility in Juniper MX-960 to configure the same
Physical Port to support L2 Bridging ie Trunk Link and also configure
same time for L3 Routing ie Sub-interfaces.
It would look something like this as listed below
{master}[edit]
root at Junos# set interfaces ae1 unit 0 family ethernet-switching port-
mode trunk
root at JUnos# set interfaces ae1 unit 0 family ethernet-switching vlan
members [ 71-73 573 ]
root at JUnos#set interfaces ae1 unit 79 vlan-id 79 family inet address 1.1.1.1/30
? ?ge-0/0/5 {
? ?flexible-vlan-tagging;
? ?encapsulation flexible-ethernet-services;
? ? ? ?unit 0 {
? ? ? ? ? ?encapsulation vlan-bridge;
? ? ? ? ? ?family bridge {
? ? ? ? ? ? ? ?interface-mode trunk;
? ? ? ? ? ? ? ?vlan-id-list [ 130 131 ];
? ? ? ? ? ?}
? ? ? ?}
? ? ? ?unit 32 {
? ? ? ? ? ?vlan-id 32;
? ? ? ? ? ?family inet {
? ? ? ? ? ? ? ?address 192.168.54.2/30;
? ? ? ? ? ?}
? ? ? ?}
? ? ? ?unit 210 {
? ? ? ? ? ?vlan-id 210;
? ? ? ? ? ?family inet {
? ? ? ? ? ? ? ?address 192.168.54.177/30;
? ? ? ? ? ?}
? ? ? ?}
? ?}
_______________________________________________
juniper-nsp mailing list juniper-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
--
Bill Blackford
Network Engineer

Logged into reality and abusing my sudo privileges.....
vaibhava varma
2011-09-24 04:35:57 UTC
Permalink
Hi Bill/ Eric

Thanks a lot for the clarification . So my final config would look
like as this below for supporting Trunking and configuring
sub-interface based L3 Links on the same ae link.

ae0 {
? ? ? ?description "Trunk Handoff";
? ? ? ?flexible-vlan-tagging;;
? ? ? ?encapsulation flexible-ethernet-services;
? ? ? ?unit 0 {
? ? ? ? ? ?encapsulation vlan-bridge;
? ? ? ? ? ?family bridge {
? ? ? ? ? ? ? ?interface-mode trunk;
? ? ? ? ? ? ? ?vlan-id-list [ xxx yyy zzz ];
? ? ? ? ? ?}
? ? ? ?}
? ? ? ?unit 10 {
? ? ? ? ? ?description L3-Int;
? ? ? ? ? ?vlan-id 10;
? ? ? ? ? ?family inet {
? ? ? ? ? ? ? ?address xx.xx.xx.yy/30;
? ? ? ? ? ?}
? ? ? ?}
Regards
Varma
ae0 {
? ? ? ?description "Single Handoff";
? ? ? ?vlan-tagging;
? ? ? ?encapsulation flexible-ethernet-services;
? ? ? ?unit 400 {
? ? ? ? ? ?encapsulation vlan-bridge;
? ? ? ? ? ?vlan-id 400;
? ? ? ?}
? ? ? ?unit 500 {
? ? ? ? ? ?description SD-500;
? ? ? ? ? ?vlan-id 500;
? ? ? ? ? ?family inet {
? ? ? ? ? ? ? ?filter {
? ? ? ? ? ? ? ? ? ?input 100M-LIMIT;
? ? ? ? ? ? ? ? ? ?output 100M-LIMIT;
? ? ? ? ? ? ? ?}
? ? ? ? ? ? ? ?address xx.xx.xx.41/30;
? ? ? ? ? ?}
? ? ? ?}
? ? ? ?unit 501 {
? ? ? ? ? ?description SD-501;
? ? ? ? ? ?vlan-id 501;
? ? ? ? ? ?family inet {
? ? ? ? ? ? ? ?filter {
? ? ? ? ? ? ? ? ? ?input 200M-LIMIT;
? ? ? ? ? ? ? ? ? ?output 200M-LIMIT;
? ? ? ? ? ? ? ?}
? ? ? ? ? ? ? ?address xx.xx.xx.45/30;
? ? ? ? ? ?}
? ? ? ?}
? ?}
-----Original Message-----
From: juniper-nsp-bounces at puck.nether.net [mailto:juniper-nsp-
bounces at puck.nether.net] On Behalf Of vaibhava varma
Sent: Friday, September 23, 2011 7:30 AM
To: juniper-nsp at puck.nether.net
Subject: [j-nsp] Juniper-MX-960-Using the same Ge-Port as L2 and L3 !
Dear All
Is there is a possibility in Juniper MX-960 to configure the same
Physical Port to support L2 Bridging ie Trunk Link and also configure
same time for L3 Routing ie Sub-interfaces.
It would look something like this as listed below
{master}[edit]
root at Junos# set interfaces ae1 unit 0 family ethernet-switching port-
mode trunk
root at JUnos# set interfaces ae1 unit 0 family ethernet-switching vlan
members [ 71-73 573 ]
root at JUnos#set interfaces ae1 unit 79 vlan-id 79 family inet address 1.1.1.1/30
? ?ge-0/0/5 {
? ?flexible-vlan-tagging;
? ?encapsulation flexible-ethernet-services;
? ? ? ?unit 0 {
? ? ? ? ? ?encapsulation vlan-bridge;
? ? ? ? ? ?family bridge {
? ? ? ? ? ? ? ?interface-mode trunk;
? ? ? ? ? ? ? ?vlan-id-list [ 130 131 ];
? ? ? ? ? ?}
? ? ? ?}
? ? ? ?unit 32 {
? ? ? ? ? ?vlan-id 32;
? ? ? ? ? ?family inet {
? ? ? ? ? ? ? ?address 192.168.54.2/30;
? ? ? ? ? ?}
? ? ? ?}
? ? ? ?unit 210 {
? ? ? ? ? ?vlan-id 210;
? ? ? ? ? ?family inet {
? ? ? ? ? ? ? ?address 192.168.54.177/30;
? ? ? ? ? ?}
? ? ? ?}
? ?}
_______________________________________________
juniper-nsp mailing list juniper-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
--
Bill Blackford
Network Engineer
Logged into reality and abusing my sudo privileges.....
_______________________________________________
juniper-nsp mailing list juniper-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
--
Regards
Vaibhava Varma
Loading...